วิธี Configure vPC บน Cisco Nexus Switch

Cisco vPC เป็นการทำ Vritual Port-Channel ซึ่ง Cisco ได้ Launch ออกมาตั้งแต่ปี 2009 บนอุปกรณ์ Datacenter ของ Cisco ซึ่งเรียกว่า Nexus Switch ซึ่งจะทำให้สามารถทำ Link Aggregation หรือ Port Channel ข้ามสวิตช์หลาย ๆ ตัวได้ ความหมายคือพอร์ตที่ทำ Link Aggregation ไม่จำเป็นต้องอยู่บนสวิตช์ตัวเดียวกันอีกต่อไปนั่นเอง

เรามาดูวิธีการ Configure vPC แบบ Step by Step กันนะครับ โดยไดอะแกรมของอุปกรณ์ที่ทำตามรูปด้านล่างนี้ครับ

1.ทำการ Enable Feature บน Nexus Switch ขึ้นมาใช้งานก่อน โดยเราจะ enable feature ทั้ง vpc และ lacp เพื่อทำ Link Aggregation สำหรับคนที่ยังไม่เคย configure Nexus Switch มาก่อนเลยนะครับ ตัว Nexus จะไม่เหมือน Network Switch ที่เป็น Catalyst แบบเดิมของ Cisco ซึ่งไม่จำเป็นต้องเปิด Feature ก่อน เพียงแค่ซื้อ License ให้ตรงตามการใช้งานก็สามารถใช้งานได้เลยเช่น LAN Base, IP Base, IP Services เป็นต้น

เราจะทำการ Enable feature บน Nexus ทั้งตัวที่ 1 และ 2 ขึ้นมานะครับ

Nexus-1:
Nexus-1(config)# feature vpc
Nexus-1(config)# feature lacp

Nexus-2:
Nexus-2(config)# feature vpc
Nexus-2(config)# feature lacp

2.ทำการ Configure Keep Alive Link

สำหรับ Keep Alive Link เราจะใช้ Management Interface ที่เป็น out of band management ทำการเชื่อมต่อเข้าหาระหว่างสวิตช์

Nexus-1:
Nexus-1(config)# interface mgmt 0
Nexus-1(config-if)# ip address 10.1.1.1/30
Nexus-1(config-if)# no shutdown

Nexus-2:
Nexus-2(config)# interface mgmt 0
Nexus-2(config-if)# ip address 10.1.1.2/30
Nexus-2(config-if)# no shutdown

ทำการ ping ip management ที่สร้างขึ้นมา เพื่อตรวจสอบจาก Nexus-1 ไปยัง Nexus-2

Nexus-1# ping 10.1.1.2 vrf management
PING 10.1.1.2 (10.1.1.2): 56 data bytes
36 bytes from 1.1.1.1: Destination Host Unreachable Request 0 timed out
64 bytes from 10.1.1.2: icmp_seq=1 ttl=254 time=1.098 ms
64 bytes from 10.1.1.2: icmp_seq=2 ttl=254 time=0.598 ms
64 bytes from 10.1.1.2: icmp_seq=3 ttl=254 time=0.536 ms
64 bytes from 10.1.1.2: icmp_seq=4 ttl=254 time=0.503 ms

— 10.1.1.2 ping statistics —
5 packets transmitted, 4 packets received, 20.00% packet loss
round-trip min/avg/max = 0.503/0.683/1.098 ms

3.ทำการสร้าง vPC Domain ซึ่งจะมีค่าตั้งแต่ 1-1000 และทำการกำหนด priotities ให้กับ Nexus ทั้ง 2 ตัว priority ที่ต่ำกว่าจะเป็น Primary

Nexus-1:
Nexus-1(config)# vpc domain 1
Nexus-1(config-vpc-domain)# role priority 20
Nexus-1(config-vpc-domain)# peer-keepalive destination 10.1.1.2 source 10.1.1.1 vrf management
Nexus-1(config-vpc-domain)#

Nexus-2:
Nexus-2(config)# vpc domain 1
Nexus-1(config-vpc-domain)# role priority 30
Nexus-2(config-vpc-domain)# peer-keepalive destination 10.1.1.1 source 10.1.1.2 vrf management
Nexus-2(config-vpc-domain)#

4.ทำการ Configure Peer Link เพื่อแลกเปลี่ยนสถานะ และ control traffic ระหว่างสวิตช์ Nexus ซึ่งเราจะทำอยู่ภายใต้ Interface ของ Port-Channel

Nexus-1:
Nexus-1(config)# interface ethernet 1/1-2
Nexus-1(config-if-range)# channel-group 20 mode active
Nexus-1(config-if-range)# no shutdown

Nexus-1(config)# interface port-channel 20
Nexus-1(config-if)# no shutdown
Nexus-1(config-if)# switchport
Nexus-1(config-if)# switchport mode trunk
Nexus-1(config-if)# vpc peer-link

Nexus-2:
Nexus-2(config)# interface ethernet 1/1-2
Nexus-2(config-if-range)# channel-group 20 mode active
Nexus-1(config-if-range)# no shutdown

Nexus-2(config)# interface port-channel 20
Nexus-2(config-if)# no shut
Nexus-2(config-if)# switchport
Nexus-2(config-if)# switchport mode trunk
Nexus-2(config-if)# vpc peer-link

ตรวจสอบสถานะด้วย command “show vpc brief”

Nexus-1# show vpc brief
Legend:
(*) – local vPC is down, forwarding via vPC peer-link

vPC domain id : 1
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : –
Graceful Consistency Check : Enabled
Auto-recovery status : Disabled
Delay-restore status : Timer is off.(timeout = 30s)
Delay-restore SVI status : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router : Disabled

vPC Peer-link status
———————————————————————
id Port Status Active vlans
— —- —— ————————————————-
1 Po20 up 1

5.ทำการ Configure Port Member เป็นพอร์ตติดต่อไปยังอุปกรณ์ปลายทาง ในไดอะแกรมนี้จะติดต่อไปยัง Switch ที่เป็นฝั่ง Leaf ครับ

Nexus-1:
Nexus-1(config)# interface eth 1/3
Nexus-1(config-if)# channel-group 30 mode active
!
Nexus-1(config-if)# interface port-channel 30
Nexus-1(config-if)# switchport
Nexus-1(config-if)# switchport mode access
Nexus-1(config-if)# switchport access vlan 30
Nexus-1(config-if)# vpc 30

Nexus-2:
Nexus-2(config)# interface eth 1/3
Nexus-2(config-if)# channel-group 30 mode active
!
Nexus-2(config-if)# interface port-channel 30
Nexus-2(config-if)# switchport
Nexus-2(config-if)# switchport mode access
Nexus-2(config-if)# switchport access vlan 30
Nexus-2(config-if)# vpc 30

ทำการตรวจสอบด้วย command show vpc brief

Nexus-1# show vpc brief
Legend:
(*) – local vPC is down, forwarding via vPC peer-link

vPC domain id : 1
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary
Number of vPCs configured : 1
Peer Gateway : Disabled
Dual-active excluded VLANs : –
Graceful Consistency Check : Enabled
Auto-recovery status : Disabled
Delay-restore status : Timer is off.(timeout = 30s)
Delay-restore SVI status : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router : Disabled

vPC Peer-link status
———————————————————————
id Port Status Active vlans
— —- —— ————————————————-
1 Po20 up 1

vPC status
—————————————————————————-
Id Port Status Consistency Reason Active vlans
— ———— —— ———– —— —————
30 Po30 down* success success 30

เราจะเห็นว่า พอร์ต Po30 ขึ้นมาแล้วแต่สถานะยัง Down อันเนื่องมาจากเราต้อง Configure ตัว Leaf Switch ด้านล่างให้เป็น Link Aggregation เพื่อมาคุยกับ Nexus ทั้ง 2 ตัวด้วย

ทั้งหมดนี้เป็นการ Configure สวิตช์ Nexus ซึ่งง่ายและไม่ยากเลยครับ สำหรับ Datacenter ในหลาย ๆ องค์กรก็เริ่มหันมาใช้งาน Nexus กันมากขึ้นเนื่องจาก Latency ต่ำ และประสิทธิภาการทำงานก็เหมาะกับห้อง Datacenter

ขอบคุณสำหรับการติดตามอย่างต่อเนื่อง หากเนื้อหาเป็นประโยชน์ ฝากกด Like เพื่อติดตามข่าวสารของ AbleNet กดแชร์ให้เพื่อน ๆ คนอื่นด้วยนะครับ ไว้เจอบทความใหม่ ๆ ที่ให้สาระ ความรู้ในการทำงานสาย Network และ System เพื่อการทำงานที่ง่ายและเสร็จตามความต้องการของเรานะครับ

ที่มาและศึกษาเพิ่มเติมได้จาก https://www.letsconfig.com/how-to-configure-cisco-nexus-vpc