การสร้าง Home Office เองที่บ้าน ด้วย Cisco Router และ L2 Switch

Home Office เป็นสิ่งที่ให้ประโยชน์มากมายทั้งต่อผู้จัดการ และพนักงานออฟฟิศในยุคนี้อย่างมาก ทั้งเรื่องการลดระยะเวลาการเดินทาง ที่ไม่ต้องเจอปัญหารถติดอีกต่อไป ลดค่าใช้จ่ายบางอย่างที่ไม่จำเป็น สามารถปรับรูปแบบการทำงานให้เข้ากับ Life Style ชีวิตของแต่ละคนได้อย่างอิสระ และอื่นๆอีกมากมาย หลายคนจึงคิดว่า มันคงไม่ง่ายเลยที่จะทำออฟฟิศเองที่บ้าน จะต้องมี Cost ที่สูง ต้องใช้บุคลากรที่มีความชำนาญการด้าน Network เพื่อมาบริหารจัดการ รวมถึงค่าใช้จ่ายที่แสนแพงในการติดตั้ง, เดินสาย, Configure และอื่นๆอีกมากมาย ทำให้คนส่วนใหญ่เลือกที่จะเช่า Office และให้พนักงานเข้ามานั่งทำงานร่วมกันมากกว่า แต่ความเป็นจริงแล้ว การทำ Home Office นั้นไม่ได้มีความยากและซับซ้อนมากขนาดนั้น และทุกๆคนสามารถทำเองได้ โดยบทความในวันนี้จะว่าด้วยเรื่องการทำ Home Office เองที่บ้าน ด้วยอุปกรณ์เพียงไม่กี่ชิ้น และวิธีการที่สามารถทำตามได้ง่ายๆ Step-by-Step

อุปกรณ์ที่จำเป็นต้องใช้

– Cisco Catalyst 2960 Series Switch (Layer 2 Switch)
       รายละเอียดผลิตภัณฑ์ : คลิกที่นี่

– Cisco 1941 Series Integrated Services Router
      รายละเอียดผลิตภัณฑ์ : คลิกที่นี่ 

– สาย Lan 3 เส้น

– สาย Console (แนะนำเป็นแบบ RJ45 – USB เพื่อความสะดวกในการใช้งาน)

– Internet with Modem from Service Provider

หลังจากที่เตรียมอุปกรณ์ครบถ้วน และ ISP (Internet Service Provider) ติดตั้ง Internet ให้เสร็จสิ้นแล้ว ทางผู้ให้บริการจะมี ONU (Optical Network Unit) หรือก็คือ Fiber Optic Modem แถมมาให้ เพื่อรับสัญญาณ Internet จากสาย Fiber แปลงเป็นสัญญาณ digital สำหรับใช้งานภายในบ้านของเรา เมื่อนำมารวมกับอุปกรณ์ที่เราได้เตรียมไว้ ก็พร้อมแล้วสำหรับการทำ Home Office โดยสามารถทำตามขั้นตอนได้ดังนี้

วิธีการสร้าง Home Office Network

1.นำสาย LAN เสียบจาก ISP Modem เข้ากับ Cisco 1941 Series Router หลังจากนั้นนำสาย LAN อีกเส้นหนึ่งเชื่อมต่อจาก Router เข้ากับ Cisco 2950-24 Switch และนำสาย LAN เส้นสุดท้ายเชื่อมต่อจาก Switch เข้ากับ TEST PC ตามรูปด้านล่าง (เส้นสีดำ = สาย LAN)

2.Power on Router และ Switch จากนั้นรอสักครู่

3.นำสาย Console ไปเสียบที่ Console Port ของ Router และ USB Port ของ THIS PC  (สาย Console = เส้นสีแดง)
    **สังเกตว่า Console Port จะมีคำว่า Console อยู่ที่ Port นั้นๆ บนตัวอุปกรณ์

4.ตรวจสอบ Port ของ Console จาก Device Manager บน THIS PC

5.จากนั้นใช้โปรแกรม Xshell เพื่อ Configure การทำงานของ Router

     ลิงค์ดาวน์โหลดโปรแกรม Xshell :คลิกที่นี่

5.1 หลังจากเข้าโปรแกรมมาแล้ว ให้คลิก File > New

5.2 เลือก Protocol เป็น Serial และตั้งชื่อ Session จากนั้นคลิก OK

6. ดับเบิ้ลคลิกที่ Serial Port ที่สร้างไว้ จะปรากฎหน้า CLI (Command Line Interface) บน Router ให้พิมพ์คำสั่ง “enable” จากนั้นทำการ คัดลอกคำสั่งด้านล่างนี้ไปวาง

config terminal
int gi 0/0
ip addr dhcp
ip nat outside
no shut
exit
int gi 0/1.2
encapsulation dot1q 2
ip addr 192.168.2.1 255.255.255.0
ip nat inside
exit
int gi 0/1.99
encapsulation dot1q 99
ip addr 192.168.99.1 255.255.255.0
ip nat inside
exit
int gi 0/1
no shut
exit
access-list 1 permit 192.168.2.0 0.0.0.255
access-list 2 permit 192.168.99.0 0.0.0.255
ip nat inside source list 1 interface gi 0/0 overload
ip nat inside source list 2 interface gi 0/0 overload

7. จากนั้นย้ายสาย Console จาก Router มาเสียบที่ Console Port ด้านหลังของ Cisco Switch 2950-24 Series (สาย Console = เส้นสีแดง) ตามรูปด้านล่าง

8. ใช้โปรแกรม Xshell ในข้อที่ 5. เพื่อ Configure การทำงานของ Switch
**หากใช้สาย Console เส้นเดิม ไม่จำเป็นต้องสร้าง Session ใหม่  สามารถคลิกที่ Session เดิมที่ใช้กับ Router ได้เลย

9. เมื่อเข้ามาหน้า CLI บน Switch ให้พิมพ์คำสั่ง “enable” จากนั้นทำการ คัดลอกคำสั่งเหล่านี้ไปวาง

config terminal
int fa 0/1
switchport mode trunk
exit
vlan 2
name HOME_OFFICE
exit
vlan 99
name MGMT
exit
int range fa 0/1-24
switchport mode access
switchport access vlan 2
span portfast
no shut
exit

10. นำสาย Console ออกจาก Console Port บน Switch จากนั้น Power on TEST PC แล้วทำการทดสอบการใช้งาน Internet ได้